"NTLDR Is Missing" Error Message When You Upgrade or
Install Windows 2000 Over Windows 95, Windows 98 or Windows
Millennium Edition
Article ID |
: |
255220 |
Last Review |
: |
November 5, 2003 |
Revision |
: |
1.0 |
This article was previously published
under Q255220
For a Microsoft Windows XP version of
this article, see 314057.
SYMPTOMS
When you attempt to install Windows
2000, or to upgrade a Microsoft Windows 95-based, Microsoft Windows
98-based, or Microsoft Windows Millennium Edition (Me)-based
computer to Windows 2000, you may receive the following error
message after the first reboot:
NTLDR is missing
Press any key
to restart
This behavior occurs only if
Windows 95, Windows 98, or Windows Me is installed on a
large-capacity drive that uses the FAT32 file system.
CAUSE
This behavior occurs because the
Windows 95, Windows 98, or Windows Me installation was improperly
cloned on a different-geometry drive and the following conditions
also exist:
• |
The system/boot partition is
formatted with the FAT32 file system. |
• |
The computer boots using INT-13
extensions (a partition larger than 7.8 gigabytes with a
System-ID type of 0C in the partition table). |
• |
The Heads (sides) value in the
FAT32 BIOS Parameter Block (BPB) is inaccurate. This must
match the geometry of the physical
drive. |
The Windows 95,
Windows 98, or Windows Me boot code ignores the head value in the
BPB and boots even when it is invalid. The Windows 2000 boot code
uses this value and causes the boot process not to succeed if it is
inaccurate.
RESOLUTION
To resolve this behavior, correct the
invalid Heads (sides) value in the FAT32 BPB to enable the Windows
2000 boot process to continue. The easiest way to update the field
is to rewrite the Windows 95, Windows 98, or Windows Me boot code by
using the following procedure:
1. |
Restart the computer with a
Windows 95, Windows 98, or Windows Me Startup disk that
contains the Sys.com file (this file is included by
default). |
2. |
At a command prompt, type sys c:. This command rewrites the
Windows 95, Windows 98, or Windows Me boot code with accurate
BPB information. If this is successful, skip to step
3.
If you are using a Windows Me startup disk and
receive an error, indicating that the command "Cannot find the
system file in the standard locations on drive C:", this
indicates that one or more files in the Windows Me
installation have been removed. Use the following steps to
place the correct files on the drive so that the sys
command can access them:
a. |
Change to the c:\Windows
prompt using the following commands:
c: cd\windows NOTE: If Windows is installed to a
different directory, you will need to adjust the above
commands accordingly. |
b. |
Try to change to the Command
directory by using the following command:
cd
command If you receive
an error indicating that the path is not found, use the
following command to create the folder and then repeat
the command above:
md
command |
c. |
Change to the EBD folder
using the following command:
cd
ebd If you receive an
error indicating that the path is not found, use the
following command to create the folder and then repeat
the command above:
md
ebd |
d. |
In the EBD folder, use the
following commands to copy the io.sys file from the root
of the hard drive and rename it to winboot.sys, which is
the file sys.com needs to transfer the system:
attrib -s -h -r
c:\io.sys copy c:\io.sys
winboot.sys |
e. |
Then change back to the A
drive and sys the drive using the following
commands:
a: sys
c: | |
3. |
Restart the computer to Windows
95, Windows 98, or Windows Me, and then attempt the Windows
2000 installation or upgrade procedure
again.
NOTE: Alternately, after you run the
sys c: command you can boot to the Recovery Console,
and then use the fixboot command to rewrite the Windows
2000 boot code. This procedure enables the original
installation to proceed typically. |
STATUS
Microsoft has confirmed that this is a
problem in the Microsoft products that are listed at the beginning
of this article.
APPLIES TO
• |
Windows 2000 Professional
Edition |
kberrmsg kbenv kbsetup kbprb KB255220
|