Here is an excellent tip from Glenn Gillen. Check his site out at
Eye of Photoshop Tips and Tricks


Begin with a blank image and place some black text on it. CTRL+Click on this
layer, and choose Select>Save Selection. Open the channels palette and duplicate channel #4.



Select channel #5, and apply Filter>Blur>Gaussian Blur with a value of 2.
Then Filter>Stylize>Glowing Edges with values of 2, 2, 2.



Load up the RGB channel, and select our layer with the text on it.
Make sure "Preserve Transparency" is not on, and then Edit>Fill>50% Gray. Then Filter>Render>Lighting Effects with an Omni light, and channel #5 as the texture channel. Make sure white is high is ticked, and the height setting is not too high. Now apply Filter>Texture>Grain with values of 13, 50, regular.



Load selection #4, and Select>Modify>Expand with a value of 3.
CTRL+Shift+I to inverse the selection, then Del to clear the surrounding area. With the selection still loaded, create a new layer below the metal text. CTRL+Shift+I to inverse the selection again, and then Select>Modify>Expand with a value of 1. Hit D to restore default colours, and then ALT+Del to fill with black. CTRL+D to deselect everything.



Apply Filter>Blur>Gaussian Blur with a value of 2. Press V
to choose the move tool, and use the arrow keys to move the shadow until your are happy. And that is it.



Photoshop tips